Strumenti Utente

Strumenti Sito


it:install_aircrack

Differenze

Queste sono le differenze tra la revisione selezionata e la versione attuale della pagina.

Link a questa pagina di confronto

Entrambe le parti precedenti la revisione Revisione precedente
Ultima revisione Entrambe le parti successive la revisione
it:install_aircrack [2010/01/10 17:04]
mister_x Compiling sqlite isn't needed anymore on cygwin
it:install_aircrack [2010/01/10 17:08]
mister_x Updated install guide (links, version)
Linea 10: Linea 10:
   * Necessario OpenSSL (versione di sviluppo). Viene chiamato openssl-dev o libssl-dev in base alla distribuzione che stai utilizzando.   * Necessario OpenSSL (versione di sviluppo). Viene chiamato openssl-dev o libssl-dev in base alla distribuzione che stai utilizzando.
 \\ \\
-Quanto segue è opzionale (ma necessario se vuoi [[airolib-ng]]):​+Quanto segue è opzionale (ma necessario se vuoi [[:airolib-ng]]):​
  
   * Necessario SQLite (versione di sviluppo) > 3.3.17 (ma si raccomanda l'​ultima versione)   * Necessario SQLite (versione di sviluppo) > 3.3.17 (ma si raccomanda l'​ultima versione)
Linea 19: Linea 19:
   * Necessario OpenSSL (versione di sviluppo): openssl-devel   * Necessario OpenSSL (versione di sviluppo): openssl-devel
 \\ \\
-Quanto segue è opzionale (ma necessario se vuoi [[airolib-ng]]):​+Quanto segue è opzionale (ma necessario se vuoi [[:airolib-ng]]):​
  
-  * Necessario SQLite (versione di sviluppo) > 3.3.17 (ma si raccomanda l'​ultima versione). Non esiste il pacchetto per cygwin e quindi deve essere compilato da sorgenti.+  * Necessario SQLite (versione di sviluppo) > 3.3.17 (ma si raccomanda l'​ultima versione): libsqlite3-devel.
  
 ==== Compilare e installare ==== ==== Compilare e installare ====
Linea 28: Linea 28:
 Sono richieste le seguenti librerie: Sono richieste le seguenti librerie:
   * Necessario OpenSSL (libssl-dev su distribuzioni basate su Debian)   * Necessario OpenSSL (libssl-dev su distribuzioni basate su Debian)
-  * Necessario SQLite > 3.3.17 (ma si raccomanda l'​ultima versione) se vuoi utilizzare [[airolib-ng]]+  * Necessario SQLite > 3.3.17 (ma si raccomanda l'​ultima versione) se vuoi utilizzare [[:airolib-ng]]
  
  
-   wget http://​download.aircrack-ng.org/​aircrack-ng-1.0-rc1.tar.gz +   wget http://​download.aircrack-ng.org/​aircrack-ng-1.0.tar.gz 
-   tar -zxvf aircrack-ng-1.0-rc1.tar.gz +   tar -zxvf aircrack-ng-1.0.tar.gz 
-   cd aircrack-ng-1.0-rc1+   cd aircrack-ng-1.0
    make    make
    make install    make install
Linea 133: Linea 133:
  
 Seguono i passi da seguire per Windows XP: Seguono i passi da seguire per Windows XP:
-  * Scarica l'​ultima versione della suite aircrack-ng per Windows sul tuo PC. Il link per il download lo puoi trovare nella [[main|Pagina Principale]].+  * Scarica l'​ultima versione della suite aircrack-ng per Windows sul tuo PC. Il link per il download lo puoi trovare nella [[:main|Pagina Principale]].
  
   * Estrai il contenuto del file zip dentro "​C:​\"​. Questo creerà una directory chiamata "​aircrack-ng-0.9.3-win"​. Il nome di questa directory cambierà in base alla versione che avrai scaricato. La directory contiene tre sottodirectory - "​bin",​ "​src"​ e "​test"​.   * Estrai il contenuto del file zip dentro "​C:​\"​. Questo creerà una directory chiamata "​aircrack-ng-0.9.3-win"​. Il nome di questa directory cambierà in base alla versione che avrai scaricato. La directory contiene tre sottodirectory - "​bin",​ "​src"​ e "​test"​.
Linea 139: Linea 139:
   * Scarica manualmente i files seguenti e mettili nella solita directory che contiene il file airodump-ng.exe.[[http://​www.tuto-fr.com/​tutoriaux/​crack-wep/​fichiers/​wlan/​winxp/​Peek.zip|Peek.dll e Peek5.sys]]   * Scarica manualmente i files seguenti e mettili nella solita directory che contiene il file airodump-ng.exe.[[http://​www.tuto-fr.com/​tutoriaux/​crack-wep/​fichiers/​wlan/​winxp/​Peek.zip|Peek.dll e Peek5.sys]]
  
-Prima di utilizzare il software, assicurati di aver installato i driver per la tua scheda di rete. Vedi questo [[install_drivers#​windows|link]] per le istruzioni.+Prima di utilizzare il software, assicurati di aver installato i driver per la tua scheda di rete. Vedi questo [[:install_drivers#​windows|link]] per le istruzioni.
  
 Ora, per utilizare la suite aircrack-ng,​ fai doppio click su **Aircrack-ng GUI.exe** dentro la directory "​bin"​. L'​interfaccia grafica richiede [[http://​www.microsoft.com/​downloads/​details.aspx?​familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&​displaylang=en|.NET Framework 2.0]] per funzionare (.NET Framework 3.0 o 1.0/1.1 non vanno bene per far girare questo eseguibile, la versione 2.0 **DEVE** essere installata). Ora, per utilizare la suite aircrack-ng,​ fai doppio click su **Aircrack-ng GUI.exe** dentro la directory "​bin"​. L'​interfaccia grafica richiede [[http://​www.microsoft.com/​downloads/​details.aspx?​familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&​displaylang=en|.NET Framework 2.0]] per funzionare (.NET Framework 3.0 o 1.0/1.1 non vanno bene per far girare questo eseguibile, la versione 2.0 **DEVE** essere installata).
Linea 150: Linea 150:
 **Note Importanti**: ​ **Note Importanti**: ​
   * Ricordati che la versione per windows non supporta tutti i comandi che sono disponibili nella versione originale della suite.   * Ricordati che la versione per windows non supporta tutti i comandi che sono disponibili nella versione originale della suite.
-  * Alcuni metodi per risolvere problemi relativi a XP e Vista sono disponibili in questa [[airodump-ng|pagina]].+  * Alcuni metodi per risolvere problemi relativi a XP e Vista sono disponibili in questa [[:airodump-ng|pagina]].
  
 ===== Mac OSX ===== ===== Mac OSX =====
it/install_aircrack.txt · Ultima modifica: 2013/06/19 21:47 da mister_x