User Tools

Site Tools


mac80211

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision Both sides next revision
mac80211 [2010/11/17 02:46]
netrolller3d Add brcm80211. (It is unsupported and known to be broken, but add it for the sake of completeness.)
mac80211 [2013/02/04 12:51]
jano updated link to iw
Line 72: Line 72:
 Airmon-ng supports mac80211'​s interface management features (nl80211) using a tool called **iw** (not to be confused with iwconfig). iw is called automatically by the airmon-ng script, or you might also call it directly to set up monitor interfaces. Airmon-ng supports mac80211'​s interface management features (nl80211) using a tool called **iw** (not to be confused with iwconfig). iw is called automatically by the airmon-ng script, or you might also call it directly to set up monitor interfaces.
  
-Iw is not part of the aircrack-ng suite. ​ You can download it from [[http://wireless.kernel.org/​download/​iw/​|here]]. Choose the latest version, or at least 0.9.5. Iw requires a recent version of libnl (1.0-pre8 minimum, 1.1 recommended).+Iw is not part of the aircrack-ng suite. ​ You can download it from [[http://www.kernel.org/​pub/​software/​network/​iw/​|here]]. Choose the latest version, or at least 0.9.5. Iw requires a recent version of libnl (1.0-pre8 minimum, 1.1 recommended).
  
  
 ====Installing iw==== ====Installing iw====
-  - Download [[http://wireless.kernel.org/​download/iw/|iw]] (look for the latest version).+  - Download [[http://www.kernel.org/​pub/​software/​network/iw/|iw]] (look for the latest version).
   - Extract the iw tarball.   - Extract the iw tarball.
   - Run "​make"​ in the iw directory. If you get lots of "​undefined"​ errors or "​netlink/​genl/​genl.h:​ No such file of directory",​ then you need to install libnl-devel,​ or update libnl. **This can be risky, you might also need to update networkmanager,​ wpa_supplicant,​ hostapd and wlassistant,​ as older versions of them only work with 1.0-pre6 and earlier!**   - Run "​make"​ in the iw directory. If you get lots of "​undefined"​ errors or "​netlink/​genl/​genl.h:​ No such file of directory",​ then you need to install libnl-devel,​ or update libnl. **This can be risky, you might also need to update networkmanager,​ wpa_supplicant,​ hostapd and wlassistant,​ as older versions of them only work with 1.0-pre6 and earlier!**
mac80211.txt ยท Last modified: 2017/01/09 21:44 by mister_x