User Tools

Site Tools


madwifi-ng

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
madwifi-ng [2008/12/28 14:24]
darkaudax Added how to obtain the PCI ID under linux
madwifi-ng [2017/01/09 21:29] (current)
mister_x Mark page as deprecated.
Line 1: Line 1:
 +====== DEPRECATED ======
 +
 +**IMPORTANT NOTE**: This page is deprecated, updated documentation can be found [[install_drivers|here]]
 +
 ====== Madwifi-ng ====== ====== Madwifi-ng ======
  
Line 8: Line 12:
    ​ifconfig ath0 down    ​ifconfig ath0 down
    ​ifconfig wifi0 down    ​ifconfig wifi0 down
-   svn -r 3745 checkout http://​svn.madwifi-project.org/​madwifi/​trunk/​ madwifi-ng +   svn -r 4073 checkout http://​svn.madwifi-project.org/​madwifi/​trunk/​ madwifi-ng
-   wget http://​patches.aircrack-ng.org/​madwifi-ng-r3745.patch+
    cd madwifi-ng    cd madwifi-ng
-   patch -Np1 -i ../madwifi-ng-r3745.patch+   wget http://​patches.aircrack-ng.org/​madwifi-ng-r4073.patch 
 +   patch -N -p 1 -i madwifi-ng-r4073.patch
    ​./​scripts/​madwifi-unload    ​./​scripts/​madwifi-unload
    make    make
Line 18: Line 22:
    ​modprobe ath_pci    ​modprobe ath_pci
 \\ \\
-Important: The above example uses revision 3745 of the madwifi-ng drivers. ​ You can use the latest SVN version if you wish.  Just be aware that in some versions injection rates are low or zero.  R3745 is known to work well. 
  
 **Notes**: **Notes**:
-  * Revision 3745 or above MUST be used (latest is always recommended). Older revision are known not to work correctly (some cannot inject or some captured packets are not correct, ...) 
-  * The patch above must be applied to madwifi-ng r3745 or above. 
   * The patch is designed to eliminate invalid retries.   * The patch is designed to eliminate invalid retries.
   * At "make install",​ you may be asked if you want to remove old modules, type '​r'​ to do it.   * At "make install",​ you may be asked if you want to remove old modules, type '​r'​ to do it.
Line 38: Line 39:
  
 **NOTE:** 11n rates are not supported yet. **NOTE:** 11n rates are not supported yet.
- 
  
  
 ==== Support for Atheros AR2425 (AR5007EG) chipset (including EEE PC) - PCI ID 168c001c ==== ==== Support for Atheros AR2425 (AR5007EG) chipset (including EEE PC) - PCI ID 168c001c ====
 +
 +**NOTE:​** ​ This section is included for historical purposes. ​ The AR5007EG is now supported by the base driver instructions above.
  
 To determine the PCI ID under linux, enter "lspci -nn"​. ​ The output should look similar to this: To determine the PCI ID under linux, enter "lspci -nn"​. ​ The output should look similar to this:
Line 64: Line 66:
  
 The new official HAL (0.10.5.6) supports AR5007EG (and AR5006EG) on 32 and 64 bit systems. Use the instructions above but checkout **http://​svn.madwifi-project.org/​madwifi/​branches/​madwifi-hal-0.10.5.6/​** instead of **http://​svn.madwifi-project.org/​madwifi/​trunk/​**. The new official HAL (0.10.5.6) supports AR5007EG (and AR5006EG) on 32 and 64 bit systems. Use the instructions above but checkout **http://​svn.madwifi-project.org/​madwifi/​branches/​madwifi-hal-0.10.5.6/​** instead of **http://​svn.madwifi-project.org/​madwifi/​trunk/​**.
 +
 +Very important, prior to applying the madwifi-ng-4073.patch patch, you must edit this file.  This is because the madwifi-hal source code is slightly different from the standard madwifi-ng source code.
 +
 +Comment out the following lines like this by adding "#"​ in front of each line or just delete the lines.
 +
 +   #diff -dru madwifi-ng/​ath_hal/​ar5211/​ar5211_reset.c madwifi-ng-fixed/​ath_hal/​ar5211/​ar5211_reset.c
 +   #--- madwifi-ng/​ath_hal/​ar5211/​ar5211_reset.c ​  ​2009-07-10 01:​46:​38.000000000 +0200
 +   #+++ madwifi-ng-fixed/​ath_hal/​ar5211/​ar5211_reset.c ​    ​2009-07-10 01:​52:​18.000000000 +0200
 +   #@@ -987,7 +987,7 @@
 +   # ​      if (AH_PRIVATE(ah)->​ah_macVersion < AR_SREV_VERSION_OAHU &&
 +   # ​          ​ath_hal_getnfcheckrequired(ah,​ (HAL_CHANNEL *) chan)) {
 +   # ​              ​static const uint8_t runtime[3] = { 0, 2, 7 };
 +   #​- ​             int16_t nf, nfThresh;
 +   #​+ ​             int16_t nf, nfThresh = 0;
 +   # ​              int i;
 +   #
 +   # ​              if (!getNoiseFloorThresh(ah,​ chan, &​nfThresh))
 +   #diff -dru madwifi-ng/​ath_hal/​ar5212/​ar5212_reset.c madwifi-ng-fixed/​ath_hal/​ar5212/​ar5212_reset.c
 +   #--- madwifi-ng/​ath_hal/​ar5212/​ar5212_reset.c ​  ​2009-07-10 01:​46:​41.000000000 +0200
 +   #+++ madwifi-ng-fixed/​ath_hal/​ar5212/​ar5212_reset.c ​    ​2009-07-10 01:​53:​24.000000000 +0200
 +   #@@ -1264,7 +1264,7 @@
 +   # {
 +   # ​      ​struct ath_hal_5212 *ahp = AH5212(ah);
 +   # ​      ​struct ar5212NfCalHist *h = &​ahp->​ah_nfCalHist;​
 +   #​- ​     int16_t nf, nfThresh;
 +   #​+ ​     int16_t nf, nfThresh = 0;
 +   # ​      ​int32_t val;
 +   #
 +   # ​      if (OS_REG_READ(ah,​ AR_PHY_AGC_CONTROL) & AR_PHY_AGC_CONTROL_NF) {
 +
  
 ===== Troubleshooting Tips ===== ===== Troubleshooting Tips =====
Line 76: Line 108:
 In both cases, reboot your system afterwards. If present, do the same for ath9k. In both cases, reboot your system afterwards. If present, do the same for ath9k.
  
-==== "​iwe_stream_add_event"​ compile error message ==== 
- 
-If you get a series of compile messages similar to "​error:​ passing argument 1 of '​iwe_stream_add_event'​ from incompatible pointer type" then do the following: 
- 
-Use 
- 
-   svn checkout http://​svn.madwifi-project.org/​madwifi/​trunk/​ madwifi-ng 
- 
-Instead of following in the installation instructions 
- 
-   svn -r 3745 checkout http://​svn.madwifi-project.org/​madwifi/​trunk/​ madwifi-ng 
- 
-The problem is that on newer kernels madwifi-ng fails to compile on older SVN versions. 
  
 ==== Airodump-ng stalls ==== ==== Airodump-ng stalls ====
madwifi-ng.1230470665.txt.gz · Last modified: 2008/12/28 14:24 by darkaudax