User Tools

Site Tools


p54

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision Both sides next revision
p54 [2009/08/21 15:46]
hatake_kakashi created by hatake_kakashi
p54 [2010/01/03 11:19]
hatake_kakashi Noted p54's ability to be patched for injection.
Line 3: Line 3:
 Not to be confused with prism54 driver which is dependent on the legacy ieee80211 stack, has injection support but only supports Intersil Prism GT fullMACs. Not to be confused with prism54 driver which is dependent on the legacy ieee80211 stack, has injection support but only supports Intersil Prism GT fullMACs.
  
-Currently as of writing, there are no patches ​for injection and it is generally ​recommended ​for the user to have kernel ​version ​2.6.28 or better.+Injection ​patches ​are available but you will need to patch it against the mac80211 stack and recompile the driver. It is recommended ​that you have at least kernel 2.6.28 or above as p54 may have issues recognising firmware properly.
  
 More information on how to get the driver working can be found at [[http://​wireless.kernel.org/​en/​users/​Drivers/​p54]]. If you have difficulty understanding what filename should the firmware be named as for it to work, once you plug the device in, check the last few lines of dmesg or /​var/​log/​messages for information. More information on how to get the driver working can be found at [[http://​wireless.kernel.org/​en/​users/​Drivers/​p54]]. If you have difficulty understanding what filename should the firmware be named as for it to work, once you plug the device in, check the last few lines of dmesg or /​var/​log/​messages for information.
p54.txt ยท Last modified: 2017/01/09 21:40 by mister_x