User Tools

Site Tools


b43

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
b43 [2010/01/15 15:30]
hatake_kakashi added more PCI/device ID from broadcom's linux_sta readme file.
b43 [2018/11/22 00:15] (current)
mister_x deprecated
Line 1: Line 1:
-====== b43 ======+====== ​DEPRECATED - b43 ======
  
-b43 is the new driver for wireless cards with Broadcom chipsets. It performs quite well in terms of monitoring and injection, although it has no support for the 802.11a wireless band.+b43/​b43legacy ​is the name of the new driver for wireless ​b/g cards with Broadcom chipsets. It performs quite well in terms of monitoring and injection, although it has no support for the 802.11a wireless band.
  
 b43 is a [[mac80211]] driver, so it requires at least Aircrack-ng 1.0-rc1. b43 is a [[mac80211]] driver, so it requires at least Aircrack-ng 1.0-rc1.
Line 7: Line 7:
 ===== Is My Card Supported? ===== ===== Is My Card Supported? =====
  
-A fairly up-to-date list is kept [[http://​wireless.kernel.org/​en/​users/​Drivers/​b43#​Known_PCI_devices|here]]. At the time of writing this article, chipsets with the following PCI IDs were **unsupported** : +A fairly up-to-date list is kept [[http://​wireless.kernel.org/​en/​users/​Drivers/​b43#​Known_PCI_devices|here]]. At the time of writing this article, chipsets with the following PCI IDs are **supported**:
- +
-^ PCI ID ^ Device ID ^Product Name ^ +
-|14e4:​4313|0x4313|4311 5 Ghz| +
-|14e4:4321| | | +
-|14e4:4324| | | +
-|14e4:4325| | | +
-|14e4:​4328|0x4328|4321 Dualband| +
-|14e4:​4329|0x4329|4321 2.4 Ghz| +
-|14e4:​432a|0x432a|4321 5 Ghz| +
-|14e4:​432b|0x432b|4322 Dualband| +
-|14e4:​432c|0x432c|4322 2.4 Ghz| +
-|14e4:​432d|0x432d|4322 5 Ghz| +
-|14e4:​4353|0x4353|43224 Dualband| +
-|14e4:​4357|0x4357|43225 2.4 Ghz|+
  
 To determine the PCI ID of your wireless device under linux, enter: To determine the PCI ID of your wireless device under linux, enter:
  
-  lspci -nn+  lspci -vnn | grep 14e4 
 + 
 +//Supported VIDs table// 
 +^ PCI ID ^ Driver ^Note^ 
 +|14e4:​4311| ​ b43/​**wl** ​ | | 
 +|14e4:4313| ::: | 2.6.33+ | 
 +|14e4:4315| ::: | 2.6.33+ | 
 +|14e4:4301| b43legacy | B | 
 +|14e4:4306| ::: | G | 
 +|14e4:4320| ::: | G | 
 +|14e4:​4307| ​ **b43** ​ | G | 
 +|14e4:4312| ::: | G | 
 +|14e4:4318| ::: | G | 
 +|14e4:4319| ::: | G | 
 +|14e4:4320| ::: | G | 
 +|14e4:5354| ::: | G | 
 + 
 +If your device ID is NOT listed here, it means it is not supported by aircrack-ng at this time. 
 + 
 +**IMPORTANT**
  
-Also, if the PCI ID of your card is **14e4:​4315** (BCM4312 with a LP "Low Power" ​PHY, commonly found on laptops), you need to install the development version of the driver, since it is unsupported by the stable versions - you will get a "UNSUPPORTED PHY" ​message in dmesg if you try to use it anyway. More information is provided underway.+Some chips are covered by both the "b43" ​and "​wl"​ driver. If you have such device, you have to make sure you **blacklist** ​the "​wl" ​driver ​before ​you utilize b43, otherwise they will collide and your card will stop functioning altogether, let alone hope for injection. The "wl" ​driver does not support aircrack-ng.
  
 =====Installing the drivers===== =====Installing the drivers=====
  
-2.6.24 kernels and newer don't need any patches applied to the driver itself. The only patch that is needed (for fragmentation attack support) is the standard mac80211 frag+ack patch.+2.6.24 kernels and newer don't need any patches applied to the driver itself ​for monitor mode and packet injection. The only patch that is needed (for fragmentation attack support) is the standard mac80211 frag+ack patch.
  
-If you have the card with the 14e4:4315 PCI ID, then you need to install the compat-wireless package, since today'​s stable versions of the drivers do not support this card at all. In fact, the b43 driver is constantly being improved and using the development version of it can yield very positive results for all its users. More information,​ as well as detailed installation steps, is provided by the [[compat-wireless]] article as well as [[http://​wireless.kernel.org/​en/​users/​Drivers/​b43#​fw-b43-lp|this]].+ 
 +**Important note:​** ​If you install or update your b43 driver via [[compat-wireless|compat-wireless]], ​you have to know that the b43/ssb modules are part of your distribution'​s initramfs image. To avoid problems with loading your new b43 driver, update your initramfs image to complete the process. To do so, simply run: 
 +  sudo update-initramfs -u 
 + 
 +If you have a card with the 14e4:4315 PCI ID and a kernel lower than 2.6.33, you need to install the compat-wireless package, since today'​s stable versions of the drivers do not support this card at all. In fact, the b43 driver is constantly being improved and using the development version of it can yield very positive results for all its users. ​ More on this particular card [[http://​wireless.kernel.org/​en/​users/​Drivers/​b43#​fw-b43-lp|here]].
  
 =====Installing the firmware===== =====Installing the firmware=====
Line 84: Line 93:
  
 See this forum entry: http://​forum.aircrack-ng.org/​index.php?​topic=6434.0 See this forum entry: http://​forum.aircrack-ng.org/​index.php?​topic=6434.0
- 
b43.1263565846.txt.gz · Last modified: 2010/01/15 15:30 by hatake_kakashi